filter question

Go down

filter question Empty filter question

Post by Carly on Fri Mar 27, 2009 10:30 am

Yet ANOTHER question!

In the filter there are 3 sponges, each of a difference corse. the finest is like wool and this appears to be making the flow slow down loads.

I had a look today to see if there was a blockage as the water was always dissapearing from the pump end of the filter and i thought this was down to evaporation. when i moved the sponge media there was a huge air lock so im guessing this was todo with the water not flowing to well.

is the finest wool like media really needed as with out it things would flow a lot better. Also all it has done is get full of muck in a empty tank!

i have cleaned the 3 different media bits out in tank water, do i need to rinse out the lava rock as well or just the sponge bits?

mathew (not carly) affraid

Carly

Posts : 33
Join date : 2009-03-04

View user profile

Back to top Go down

filter question Empty Re: filter question

Post by Smigs on Wed Aug 19, 2009 9:10 am

I had the same problem with the juwel filters in my tanks. I just changed the media around abit. I put the wool further down so the filter does not get clogged up so easy, It seems to make the water alot clearer this way aswell as it gives it a good polish just before it goes back into the tank Smile
Smigs
Smigs

Posts : 17
Join date : 2009-08-19

View user profile

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum